Программно штрих-код номенклатуре 1С: Розница 2.2

Штрих-коды номенклатуры в конфигурации «1С:Розница 2.2» хранятся в регистре сведений «Штрихкоды»

Данные о штрих-коде номенклатуры можно добавить в регистр следующим кодом:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
Функция ДобавитьСтрокуТовараТабличнуюЧастьТоваровДокументаПоступления(ТабличнаяЧастьТовары, КартаПолей, ЗначенияПолей)
 
	НоменклатураСсылка = НайтиИлиСоздатьНоменклатуру(КартаПолей, ЗначенияПолей);
 
	Если НоменклатураСсылка.Пустая() Тогда
		Возврат ЛОЖЬ;
	КонецЕсли;
 
	Попытка
		Цена = Число(ЗначенияПолей[КартаПолей["price"]]);
	Исключение
		Сообщить("Ошибка получения поля ЦЕНА для номенклатуры: " + НоменклатураСсылка.Наименование + "Ошибка:" + ОписаниеОшибки());
		Возврат ЛОЖЬ;
	КонецПопытки;
 
	Количество = 1;
	Попытка
		Количество = Число(ЗначенияПолей[КартаПолей["pieces"]]);
	Исключение
	КонецПопытки;
 
	Если Количество <= 0 ИЛИ Цена <= 0 Тогда
		Возврат ЛОЖЬ;
	КонецЕсли;
 
	СтрокаТЧТовары = ТабличнаяЧастьТовары.Добавить();
	СтрокаТЧТовары.Номенклатура = НоменклатураСсылка;//
	СтрокаТЧТовары.Характеристика = Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка();
	СтрокаТЧТовары.Количество = Количество;
	СтрокаТЧТовары.КоличествоУпаковок = Количество;
 
	СтрокаТЧТовары.Цена = Цена;
	СтрокаТЧТовары.Сумма = Цена * СтрокаТЧТовары.Количество;
	СтрокаТЧТовары.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
	//СтрокаТЧТовары.КлючСвязиСерийныхНомеров =
	//СтрокаТЧТовары.Упаковка = //
	//СтрокаТЧТовары.СтатусУказанияСерий = //
	//СтрокаТЧТовары.ИдентификаторСтроки = //
	//СтрокаТЧТовары.АлкогольнаяПродукция = //
	//СтрокаТЧТовары.ИдентификаторУпаковки = // Строка(50)
	//СтрокаТЧТовары.КлючСвязи = //
	//СтрокаТЧТовары.НомерГТД = //	
 
	ОбработкаТабличнойЧастиТоварыКлиентСервер.ЗаполнитьКлючСвязи(ТабличнаяЧастьТовары, СтрокаТЧТовары, "КлючСвязи");  
 
 
	Возврат Истина;
КонецФункции

Код расположен: «Общий модуль -> ПодключаемоеОборудованиеРТВызовСервера»

Предопределенные типы штрих-кодов в 1С:

  • CODE128
  • CODE39
  • EAN128
  • EAN13
  • EAN8
  • ITF14

Этот список можно посмотреть в объекте метаданных «Планы видов характеристик.ТипыШтрихкодов»

Related Post

Программа 1с скачать бесплатноПрограмма 1с скачать бесплатно

Скачать бесплатно программу 1С можно по ссылке, которую предоставляют разработчики для демонстрации продукта англоязычному населению. Ссылка: https://1c-dn.com Данный дистрибутив подойдет для ознакомления с платформой и даст возможность разобраться в целесообразности

Проверка действий пользователей в конфигураторе 1СПроверка действий пользователей в конфигураторе 1С

В системе 1С предусмотрен журнал регистрации последовательных действий пользователей для отслеживания рабочих моментов. В базе данных отражается информация, кто из сотрудников в последний раз работал с документацией, изменял и удалял

Добавление пользователей в конфигуратор 1С.РозницаДобавление пользователей в конфигуратор 1С.Розница

Добавление пользователей в 1С подразумевает закрепление ролей за каждым, и работа с той частью документации, которая необходимо. Это позволяет обеспечить безопасность конфиденциальной информации, осуществлять контроль за работой сотрудников в целом