Программно штрих-код номенклатуре 1С: Розница 2.2

Штрих-коды номенклатуры в конфигурации «1С:Розница 2.2» хранятся в регистре сведений «Штрихкоды»

Данные о штрих-коде номенклатуры можно добавить в регистр следующим кодом:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
// Устанавливает новый штрихкод для товара.
// 
Функция УстановитьШтрихкод(Штрихкод, Владелец, Характеристика, Упаковка, ОписаниеОшибки) Экспорт
 
	НачатьТранзакцию();
 
	Попытка	
		ТипШтрихкодаРТ  = ОпределитьТипШтрихкода(Штрихкод);
 
		НовыйШтрихкод = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
		НовыйШтрихкод.Владелец = Владелец; 
		Если ПолучитьФункциональнуюОпцию("ИспользоватьХарактеристикиНоменклатуры") Тогда
			НовыйШтрихкод.Характеристика = Характеристика;
		КонецЕсли;
		Если ПолучитьФункциональнуюОпцию("ИспользоватьУпаковкиНоменклатуры") Тогда
			НовыйШтрихкод.Упаковка       = Упаковка;
		КонецЕсли;
 
		НовыйШтрихкод.ТипШтрихкода = ТипШтрихкодаРТ;
		НовыйШтрихкод.Штрихкод = Штрихкод;
		НовыйШтрихкод.Записать();
 
		ЗафиксироватьТранзакцию();
 
	Исключение
 
		ОтменитьТранзакцию();
 
		ОписаниеОшибки = НСтр("ru = 'При записи штрихкодов произошла ошибка.
		                      |Запись штрихкодов не выполнена.
		                      |Дополнительное описание:
		                      |%ДополнительноеОписание%'");
		ОписаниеОшибки = СтрЗаменить(ОписаниеОшибки, "%ДополнительноеОписание%", ИнформацияОбОшибке().Описание);
 
		Возврат Ложь;
 
	КонецПопытки;
 
	Возврат Истина;
 
КонецФункции

Код расположен: «Общий модуль -> ПодключаемоеОборудованиеРТВызовСервера»

Предопределенные типы штрих-кодов в 1С:

  • CODE128
  • CODE39
  • EAN128
  • EAN13
  • EAN8
  • ITF14

Этот список можно посмотреть в объекте метаданных «Планы видов характеристик.ТипыШтрихкодов»